EasyConnect (follow up)

Hi everyone,

Its our pleasure to inform you that EasyConnect keep on evolving .
Our new servers will be deployed today and tomorrow.

If you notice any abnormal function, please send us your comments at contact@gigatribe.com.

Thank you for your participation.

17 thoughts on “EasyConnect (follow up)

  1. I can’t access my giga. I get an error for giga 3.01.007. says i cannot be reached via internet and cannot use easy connect. how do i get my giga back up and running?

  2. Hey all out there. I’m living in beautiful Berlin Germany and in Zürich Switzerland. Hope to meet all of your tribers!

  3. says that I cant get on line by easy connect well in the first place it wasnt set up that way. and now it dont work. And your help section to fix the router dont tell you anything about how to do it. Can you tell me where you even find the folder or section to change not just say well this is what it should be. or pay someone to do it for you.

    • @pctitcher
      Hello

      If your configuration environment is complex or if you don’t feel like making any modification, you may choose to subscribe to the Ultimate offer that include the EasyConnect service:
      You will be able then to connect with EasyConnect option without any kind of configuration. Moreover, you will have an access to all GigaTribe features.

      If you want to configure a direct connection, you can find a router list here:

  4. Just for your note as I see no official bug list for 3.01.007. When I minimize Gigatribe 3.01.007 to windows task bar majority of the time when I try to open gigatribe window back up it will not open right I only see a bit of the top border. I will have to click the icon on the task bar several time to get the window to open and display correctly. A few times it would not

    Opps sorry posted message before I was done >< I run Windows 7 64bit Sp1 any other info you may need I can provide. You may already know of the issue. But again with no offical "Known bug list" I just wanted to make sure it was reported.

  5. It’s now almost 6 months since you released and pulled 3.2.4. What can you possibly be doing for this period of time. No releases, no updates on whether or not you have fixed the issues:

    – Buggy UI
    – Invisible users
    – File renaming

    The UI is especially annoying. It’s all well and good trying to give your product a unique identity but if that UI then causes problems with the functionality of the program it needs to go. If I open Giga in win7 64bit and connect, and then minimise it, if I then click on the taskbar to bring it back I get a tiny portion of the titlebar and NO PROGRAM WINDOW – it’s utterly infuriating. I have to double click on that to maximise it and then restore it down to be able to see it again. The program is THERE because I can’t click through to the desktop but it’s just invisible.

    FIX IT PLEASE. Once again I find myself regretting having given you any money because you’re not making any apparent effort to improve your program! Not even minor releases to address the problems – it leads me to believe that you haven’t got a clue why it’s not working, you don’t know how to fix it so you’re just quietly ignoring Giga and working on other projects instead.

    • @John

      Hi,

      Let me remind you that our staff has been recently modified and that is why we have some delay in the development of Gigatribe.
      A new experimented engineer has joined us and we are doing our best to present you a new version as soon as possible.
      A new post has been created to display all Known bugs.
      Thank you for your comments.

  6. i downloaded gigatribe today and tried to connect, im told i cant connect via the internet and i cant use easy connection
    i have turned off my anti virus and also turned off the fire wall but i get the same message over and over again help!!

  7. Michael!

    what the hell is this? everytime i trying connect i get this message:

    “The Servers did not respond”

    my firewall set up, so no way because of it i cannot connect!

    HELP!!!!!!!!!!!!!!

  8. ok im getting server not found this happen last night too, now ive gone to the help section to no avail, whats is the problem can you help at all

Leave a Reply to Patrick Cancel reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s